re = /^(\ ?){1,}[._\-\w]{1,25}\@[\-\w]{1,25}(\.[\-\w]{1,25}){1,3}?([\ ]{1,}?)?$/
str = ' emanuel_on@catracalivre.com.br '
# Print the match result
str.match(re) do |match|
puts match.to_s
end