// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\ ?){1,}[._\-\w]{1,25}\@[\-\w]{1,25}(\.[\-\w]{1,25}){1,3}?([\ ]{1,}?)?$").unwrap();
let string = " emanuel_on@catracalivre.com.br ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}