import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])(?=\\D*\\d)(?=[^!#%]*[!#%])[A-Za-z0-9!#%]{8,32}$";
final String string = "Must include at least 1 lower-case letter.\n"
+ "Must include at least 1 upper-case letter.\n"
+ "Must include at least 1 number.\n"
+ "Must include at least 1 special character (only the following special characters are allowed: !#%).\n"
+ "Is only allowed to include A-Za-z0-9!#% (no other characters are allowed).\n"
+ "Must be from 8 to 32 characters long.\n"
+ "Happyness1!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}