import Foundation
let pattern = #"\A[a-zA-Z0-9\s\p{Han}]+\z"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"总理话音一落 部门即抓落实 End"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}