use strict;
my $str = '
<html xmlns="http://www.w3.org/1999/xhtml" dir="rtl" lang="ar">
<head profile="http://gmpg.org/xfn/11">
<base href="http://movizland.com"/>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<title itemprop=\'name\'>مشاهدة فيلم Steve Jobs 2015 مترجم بجودة 1080p BluRay </title>
<meta name="viewport" content="width=device-width"/>
<meta http-equiv="Content-Language" content="en-us,ar"/>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<meta name="description" content="Movizland - موفيز لاند - فيلم Steve Jobs 2015 BluRay, مشاهدة فيلم Steve Jobs 2015 BluRay, تحميل , مشاهدة Steve Jobs 2015 BluRay اون لاين, Steve Jobs 2015 BluRay مترجم بلوراي, تحميل مباشر فيلم Steve Jobs 2015 BluRay, مشاهدة مباشرة لفيلم Steve Jobs 2015 BluRay, شاهد اون لاين فيلم Steve Jobs 2015 BluRay, فيلم Steve Jobs 2015 BluRay كامل مترجم, فيلم Steve Jobs 2015 BluRay مترجم كامل, تنزيل فيلم Steve Jobs 2015 BluRay, مشاهدة فيلم Steve Jobs 2015 BluRay, فيلم Steve Jobs 2015 BluRay بجودة عالية">
<meta name="keywords" content="Movizland,موفيز لاند,موفيزلاند,أفلام اجنبية,افلام,دراما,سيره ذاتيه,">
<meta http-equiv="Content-Language" content="ar-eg"/>
<meta http-equiv="Cache-Control" content="no-cache"/>
<meta http-equiv="Pragma" content="no-cache"/>
<meta name="Expires" content="0"/>
<meta name="rating" content="General"/>
<meta name="robots" content="index, follow"/>
<meta name="robots" content="NOODP,NOYDIR"/>
<meta name="revisit-after" content="1 hour"/>
<meta name="distribution" content="Global"/>
<meta name="classification" content="All"/>
<meta name="googlebot" content="archive"/>
<meta name="resource-type" content="document"/>
<meta name="author" content="Movizland .Com"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="http://movizland.com/movies/%d9%81%d9%8a%d9%84%d9%85-steve-jobs-2015-%d9%85%d8%aa%d8%b1%d8%ac%d9%85-%d8%a8%d8%ac%d9%88%d8%af%d8%a9-1080p-bluray/"/>
<script type="text/javascript">
//<![CDATA[
try{if (!window.CloudFlare) {var CloudFlare=[{verbose:0,p:0,byc:0,owlid:"cf",bag2:1,mirage2:0,oracle:0,paths:{cloudflare:"/cdn-cgi/nexp/dok3v=1613a3a185/"},atok:"2841200b99e0503213236eb6beec5cc0",petok:"0b0dd91ad9f44b84332bd5593c41a44e9283c53a-1454659108-1800",zone:"movizland.com",rocket:"a",apps:{},sha2test:0}];document.write(\'<script type="text/javascript" src="//ajax.cloudflare.com/cdn-cgi/nexp/dok3v=38857570ac/cloudflare.min.js"><\'+\'\\/script>\');}}catch(e){};
//]]>
</script>
<link itemprop="url" rel="canonical" href="http://movizland.com/movies/%d9%81%d9%8a%d9%84%d9%85-steve-jobs-2015-%d9%85%d8%aa%d8%b1%d8%ac%d9%85-%d8%a8%d8%ac%d9%88%d8%af%d8%a9-1080p-bluray/"/>
<meta property="og:title" content="فيلم Steve Jobs 2015 مترجم بجودة 1080p BluRay"/>
<meta property="og:image:secure_url" content=""/>
<meta property="og:image" content="http://movizland.com/wp-content/uploads/steve_jobs_ver2-1.jpg"/>
<meta property="og:site_name" content="Movizland"/>
<meta property="og:description" content="Movizland - موفيز لاند - فيلم Steve Jobs 2015 BluRay, مشاهدة فيلم Steve Jobs 2015 BluRay, تحميل , مشاهدة Steve Jobs 2015 BluRay اون لاين, Steve Jobs 2015 BluRay مترجم بلوراي, تحميل مباشر فيلم Steve Jobs 2015 BluRay, مشاهدة مباشرة لفيلم Steve Jobs 2015 BluRay, شاهد اون لاين فيلم Steve Jobs 2015 BluRay, فيلم Steve Jobs 2015 BluRay كامل مترجم, فيلم Steve Jobs 2015 BluRay مترجم كامل, تنزيل فيلم Steve Jobs 2015 BluRay, مشاهدة فيلم Steve Jobs 2015 BluRay, فيلم Steve Jobs 2015 BluRay بجودة عالية">
<link rel="pingback" href="http://movizland.com/xmlrpc.php"/>
<link rel="alternate" type="application/rss+xml" href="http://movizland.com/feed" title="Movizland .Com"/>
<link href=\'http://fonts.googleapis.com/css?family=Niconne\' rel=\'stylesheet\' type=\'text/css\'/>
<script type="text/rocketscript" data-rocketsrc="http://movizland.com/wp-content/themes/new/js/jquery-1.8.2.min.js"></script>
<link rel="stylesheet" type="text/css" href="http://movizland.com/wp-content/themes/new/style.css"/>
<link rel="stylesheet" type="text/css" href="http://movizland.com/wp-content/themes/new/css/font-awesome.min.css"/>
<script type="application/ld+json">
{ "@context" : "http://schema.org",
"@type" : "WebSite",
"name" : "Movizland",
"alternateName" : "Movizland.Com",
"url" : "http://movizland.com"
}
</script>
</head>
<body style="background-image:url(\'http://movizland.com/wp-content/uploads/thehungergames.jpg\');">
<header>
<div class="dropmenu-nav">
<li><a href="http://movizland.com/">الرئيسية</a> </li>
<li><a href="http://vb.movizland.com/">المنتدي</a> </li>
<li><a href="http://vb.movizland.com/f15">طلبات الافلام</a> </li>
<li><a href="http://vb.movizland.com/f20">مواضيع تهمك</a> </li>
<li><a href="http://movizland.com/vb/sendmessage.php">اتصل بنا</a> </li>
</div>
<div class="cpanel">
<li class="btn-red future-btn"> <a href="http://movizland.com/vb/t11910"> اشتراك مميز <span style="text-align: center;font-size: 13px;display: block;margin-top: -4px;margin-bottom: -3px;">خواص بلا حدود</span> </a> </li>
<li class="btn-red app-btn"> <a href="http://www.movizland.com/MovizLand_1.0.apk"> تحميل التطبيق<br> <span style="text-align: center;font-size: 13px;display: block;margin-top: -4px;margin-bottom: -3px;">لموبايل اندرويد</span> </a> </li>
</div>
<div class="center">
<div class="tiny-stars"><img src="http://movizland.com/wp-content/themes/new/img/stars2.svg" alt="Movizland .Com"></div>
<div class="tiny-stars middle-stars"><img src="http://movizland.com/wp-content/themes/new/img/stars3.svg" alt="Movizland .Com"></div>
<div class="planet-big centered">
<span class="round round-1"></span> <span class="round round-2"></span> <span class="round round-3"></span> <span class="round round-4"></span> <span class="round round-5"></span>
</div>
</div>
<div id="poster">
<div id="letter-container" class="letter-container">
<h2> <a href="http://movizland.com/"><span class="char1">M</span><span class="char2">o</span><span class="char3">v</span><span class="char4">i</span><span class="char5">z</span><span class="char6"> </span><span class="char7">L</span><span class="char8">a</span><span class="char9">n</span><span class="char10">d</span></a> <a href="http://movizland.com/" style="font-size:52px"><span class="char1">A</span><span class="char2">l</span><span class="char3">l</span><span class="char4"> </span><span class="char5">M</span><span class="char6">o</span><span class="char7">v</span><span class="char8">i</span><span class="char9">e</span><span class="char10">s</span><span class="char11"> </span><span class="char12">I</span><span class="char13">n</span><span class="char14"> </span><span class="char15">Y</span><span class="char16">o</span><span class="char17">u</span><span class="char18">r</span><span class="char19"> </span><span class="char20">H</span><span class="char21">a</span><span class="char22">n</span><span class="char23">d</span></a> </h2>
</div>
</div>
<div class="holderB"></div>
<style>div#title-movie>strong{position:absolute;top:-17px;right:14px;background:#81011D;color:white;font-weight:normal;padding:3px 10px;border-radius:4px;}div#title-movie{position:absolute;bottom:30px;right:50%;margin-right:-500px;background:black;border-radius:10px;padding:21px 20px 20px;font-size:14px;font-family:Flat;width:420px;border:2px solid #151515;box-shadow:0px 1px 26px black;}</style>
</header>
<div class="wrap"><main class="home-boxes" id="seccion2">
<script data-cfasync="false" type="text/javascript" src="//go.onclasrv.com/apu.php?zoneid=496414"></script>
<script type="text/rocketscript">
var adParams = {p: \'60161217\', serverdomain: \'wmedia\' , numOfTimes: \'1\',duration: \'5\',period: \'minute\' };
</script>
<script type="text/rocketscript" data-rocketsrc=\'http://cdn.waframedia8.com/wmedia/tags/xpopup/xpopup.js?ap=1303\'></script>
<div class="movie-single">
<h2 class="title-ribbon">
<span></span>
<strong>
جديد
</strong>
<em class="afters"></em>
<em class="befores">
فيلم Steve Jobs 2015 مترجم بجودة 1080p BluRay </em>
</h2>
<div class="ad">
<script type="text/rocketscript">
var adParams = {p: \'60401138\', size: \'728x90\', serverdomain: \'wmedia\' };
</script>
<script type="text/rocketscript" data-rocketsrc=\'http://cdn.waframedia8.com/wmedia/tags/xbanner/xbanner.js?ap=1300\'></script></div>
<div class="ad-vertical"><SCRIPT data-cfasync="false" SRC="http://bdv.bidvertiser.com/BidVertiser.dbm?pid=551769&bid=1744544" TYPE="text/javascript"></SCRIPT></div>
<div class="poster-movie">
<a href="http://vb.movizland.com/t30586"><img width="490" height="640" src="http://movizland.com/wp-content/uploads/steve_jobs_ver2-1-490x640.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="steve_jobs_ver2"/></a>
</div>
<div class="box-content" style="color: white;font-family: Flat , Arial;">
فيلم Steve Jobs 2015 BluRay, مشاهدة فيلم Steve Jobs 2015 BluRay, تحميل , مشاهدة Steve Jobs 2015 BluRay اون لاين, Steve Jobs 2015 BluRay مترجم بلوراي, تحميل مباشر فيلم Steve Jobs 2015 BluRay, مشاهدة مباشرة لفيلم Steve Jobs 2015 BluRay, شاهد اون لاين فيلم Steve Jobs 2015 BluRay, فيلم Steve Jobs 2015 BluRay كامل مترجم, فيلم Steve Jobs 2015 BluRay مترجم كامل, تنزيل فيلم Steve Jobs 2015 BluRay, مشاهدة فيلم Steve Jobs 2015 BluRay, فيلم Steve Jobs 2015 BluRay بجودة عالية <div style="height:10px;"></div>
<btns class="btns-asni-anim-1">
<span>نوع الفيلم</span>
<div class="fortermS">
<a href="http://movizland.com/all/%d8%af%d8%b1%d8%a7%d9%85%d8%a7/" title="افلام دراما">دراما</a>
<a href="http://movizland.com/all/%d8%b3%d9%8a%d8%b1%d9%87-%d8%b0%d8%a7%d8%aa%d9%8a%d9%87/" title="افلام سيره ذاتيه">سيره ذاتيه</a>
</div>
</btns>
<btns class="btns-asni-anim-2">
<span>قسم الفيلم</span>
<div class="fortermS">
<a href="http://movizland.com/cat/foreign/" title="قسم أفلام اجنبية">أفلام اجنبية</a>
<a href="http://movizland.com/cat/movies/" title="قسم افلام">افلام</a>
</div>
</btns>
<div class="progress">
<a class="RedirecTliNK" style="
background: rgb(173, 0, 79);
margin: 10px auto 0;
font-family: Flat;
border: 2px solid rgba(255, 255, 255, 0.27);
padding: 7px 15px;
font-size: 25px;" href="http://moshahda.net/lw44qevnqkn9.html">ذهاب الان</a>
</div>
<div class="ad">
<script type="text/rocketscript">
var adParams = {p: \'70248929\', size: \'300x250\', serverdomain: \'wmedia\' };
</script>
<script type="text/rocketscript" data-rocketsrc=\'http://cdn.waframedia8.com/wmedia/tags/xbanner/xbanner.js?ap=1300\'></script>
</div>
</div>
<div class="ad-vertical-2"><SCRIPT data-cfasync="false" SRC="http://bdv.bidvertiser.com/BidVertiser.dbm?pid=551769&bid=1744544" TYPE="text/javascript"></SCRIPT></div>
</div>
<style type="text/css">.progress{float:left;}.histats{clear:both;}</style>
<script type="text/rocketscript">
var adParams = {p: \'70161427\', closeButton: \'Left\' , backgroundColor: \'transparent\', size: \'320x50\',popOnClose:\'true\', serverdomain: \'wafra\',period: \'minute\', numOfTimes: \'1\',duration: \'2\' };
</script>
<script type="text/rocketscript" data-rocketsrc=\'http://cdn.waframedia8.com/wafra/tags/xcatfish/xcatfish.js?ap=1301\'></script>
</div> <div class="aligncenter histats"> <script type="text/rocketscript">(function() {var _fbq = window._fbq || (window._fbq = []); if (!_fbq.loaded) {var fbds = document.createElement(\'script\'); fbds.async = true; fbds.src = \'//connect.facebook.net/en_US/fbds.js\'; var s = document.getElementsByTagName(\'script\')[0]; s.parentNode.insertBefore(fbds, s); _fbq.loaded = true; } })(); window._fbq = window._fbq || []; window._fbq.push([\'track\', \'6022448280372\', {\'value\':\'0.00\',\'currency\':\'USD\'}]); </script> <noscript><img alt="" height="1" width="1" alt="facebook" style="display:none" src="https://www.facebook.com/tr?ev=6022448280372&cd[value]=0.00&cd[currency]=USD&noscript=1"/></noscript> <script type="text/rocketscript"> (function(i,s,o,g,r,a,m){i[\'GoogleAnalyticsObject\']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,\'script\',\'//www.google-analytics.com/analytics.js\',\'ga\'); ga(\'create\', \'UA-51106521-2\', \'auto\'); ga(\'send\', \'pageview\'); </script>
<a href="http://www.histats.com" alt="page hit counter" target="_blank">
<embed src="http://s10.histats.com/6.swf" flashvars="jver=1&acsid=2308846&domi=4" quality="high" width="200" height="40" name="6.swf" align="middle" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" wmode="transparent"/></a>
<img src="http://sstatic1.histats.com/0.gif?2308846&101" alt="free html hit counter" border="0">
</div> <div class="footer"> <div class="copyrights"> <a href="http://movizland.com" title="Movizland .Com">Movizland.com</a> </div> <div class="design"> تصميم و برمجة <a href="http://www.yourcolor.net" title="تصميم مواقع | برمجة خاصة | برمجة ووردبريس | استضافة" alt="تصميم و برمجة و استضافة">YourColor.net</a> </div> </div> <div id="overlay-closes" style="display:none;"></div> </body> </html>
';
my $regex = qr/href="(.+?)">ذهاب الان</a>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}