$re = '/\'[^\']*?\'(*SKIP)(*F)|AND/';
$str = 'parameter_1 >= \'23\' AND parameter_2 like \'cucurigu AND \\picaso\' AND parameter_3 IS NULL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);