using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";(?!(?:""[^""]*""|[^""])*$)";
string substitution = @":";
string input = @"asbas;""asd;"";asd;asdadasd;""asd;ad;s;as""";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}