use strict;
my $str = 'asbas;"asd;";asd;asdadasd;"asd;ad;s;as"';
my $regex = qr/;(?!(?:"[^"]*"|[^"])*$)/imp;
my $subst = ':';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";