re = /;(?!(?:"[^"]*"|[^"])*$)/im
str = 'asbas;"asd;";asd;asdadasd;"asd;ad;s;as"'
subst = ':'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result