using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d{2} )\+(?=\d{4})";
string input = @"[12/Oct/2015:00:37:29 +0200]
[12/Oct/2015:00:37:x9 +0200]
[12/Oct/2015:00:37:29 +020x]";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}