const regex = /(?<=\d{2} )\+(?=\d{4})/gsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d{2} )\\+(?=\\d{4})', 'gsi')
const str = `[12/Oct/2015:00:37:29 +0200]
[12/Oct/2015:00:37:x9 +0200]
[12/Oct/2015:00:37:29 +020x]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}