re = /(?<=\d{2} )\+(?=\d{4})/i
str = '[12/Oct/2015:00:37:29 +0200]
[12/Oct/2015:00:37:x9 +0200]
[12/Oct/2015:00:37:29 +020x]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end