re = /^[a-zA-Z0-9 @_+\-"\\,.\/]+$/i
str = 'B. Bala Manigandan
B.Balamanigandan
B. Balamanigandan
G.S. Sakthivel
G. S. Sakthivel
Sakthivel M.G.
GS Sakthivel
G.S. SAKTHIVEL
BALA MANIGANDAN .B
Sakthivel .M.G
#2675, Gf, Sector 23, Gurgaon
2675, Sec 23, Gurgaon
Nagaratnam s/o Suppiah.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end