using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@(.*?)\(\(property\((.*?)\)val\((.*?)\)\)";
string input = @"MyCarGarage@Mustang((property(PS)val(500))@Porsche((property(PS)val(425)).";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}