re = /@(.*?)\(\(property\((.*?)\)val\((.*?)\)\)/
str = 'MyCarGarage@Mustang((property(PS)val(500))@Porsche((property(PS)val(425)).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end