$re = '~(?:^.*?\.com/|(?<!^)\G)[^/\h]*\K/~m';
$str = '/foo/bar/baz/xyz
http://example.com/foo/12/jacket Input/Output /foo/bar/baz/xyz';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;