$re = '/[ \(\w+\)]
/';
$str = 'x (LOC)
ds ds (32C)
d\'ds ds (LeC)
ds-d da(LOQ)
12345 (deC)
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);