$re = '/([\d|\.]+)/m';
$str = 'PSU 12.1.0.2.170117';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);