use strict;
my $str = '\\servername\\logs\\e2serverd.20210107.000000.691088.log
\\servername\\logs\\e2serverd.20210107.111111.123423.log';
my $regex = qr/(.*)([0-9]{6}.[0-9]{6}.log)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}