using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z])\w+\s([A-Z])\w*\s*([A-Z])*(?=,*)";
string input = @"Bill Joney Jones, III";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}