package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([а-яА-Я.“”]+\s?)+`)
var str = `2 Цвет черный.
- Цвет черный.
- Рукав покроя “реглан”.
Цвет черный.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}