using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[2-9][0-9][0-9]\-[2-9][0-9][0-9]-[0-9][0-9][0-9][0-9]";
string input = @"999-999-9999";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}