using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=(?:(?:[^""]*\""){2})*[^""]*$)";
string input = @"1,""2,2,2"",three,'four, 4',,""6\tsix""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}