package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\$(_POST|_SESSION|_GET)\[([^\'][0-9a-zA-Z _]+?[^\'])\]`)
var str = `$_GET['banner_name']
$_GET[banner_name]
$_POST['banner_name']
$_POST[banner_name]
$_SESSION['banner_name']
$_SESSION[banner_name]
`
var substitution = "$$1['$2']"
fmt.Println(re.ReplaceAllString(str, substitution))
}