$re = '/(spec|test)\.js$/im';
$str = 'test-test-file.js
testFileSpec.js
some-file-test.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);