package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\+\-]?\d+\.?\d*[\+\-\*\/]?)`)
var str = `1001.111+232323.2221u
-1111.2
1111.222/22222/2
-11111+222.3/4
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}