import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\+\\-]?\\d+\\.?\\d*[\\+\\-\\*\\/]?)";
final String string = "1001.111+232323.2221u\n"
+ "-1111.2\n"
+ "1111.222/22222/2\n"
+ "-11111+222.3/4\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}