re = /.*(?:youtu.be\/|v\/|u\/\w\/|embed\/|watch\?v=)([^#\&\?]*).*/i
str = '<iframe width="560" height="315" src="https://www.youtube.com/embed/123?list=PLVlyYfbClWxRpOSJvalIUTBxoqkrzowzI" frameborder="0" allowfullscreen></iframe>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end