$re = '/^[A-Za-z]{2}[0-9]{2}[A-Za-z]{1,2}[0-9]{1,4}/mi';
$str = 'MH21A4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);