package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^.*[me]e)(*SKIP)(*FAIL)|e`)
var str = `met
meet
eel
elm
degree
zookeeper
meee`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}