$re = '/(\S)(\s){2,}(?=\S)/m';
$str = ' Hi, this is a good time to start working together.
Hi, this is a good time to start working together.
Hi, this is a good time to start working together. ';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;