#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)(?:.+(?:\n.)?)+"
Local $sString = "Lorem ipsum dolor sit amet, consetetur sadipscing elitr," & @CRLF & _
"sed diam nonumy eirmod tempor invidunt ut labore et dolore" & @CRLF & _
"magna aliquyam erat, sed diam voluptua. At vero eos et" & @CRLF & _
"accusam et justo duo dolores et ea rebum." & @CRLF & _
"" & @CRLF & _
"Stet clita kasd gubergren, no sea takimata sanctus est Lorem" & @CRLF & _
"ipsum dolor sit amet." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Ipsum dolor sit amet, consetetur sadipscing elitr, sed diam" & @CRLF & _
"nonumy eirmod tempor invidunt ut labore et dolore magna" & @CRLF & _
"aliquyam erat, sed diam voluptua. At vero eos et accusam et" & @CRLF & _
"justo duo dolores et ea rebum. Stet clita kasd gubergren, no" & @CRLF & _
"sea takimata sanctus est Lorem ipsum dolor sit amet." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ART. WEFWEFEW" & @CRLF & _
" 1 SDVSDRG:" & @CRLF & _
" a. wevvdfvdfd" & @CRLF & _
" b. sdfsdfsdfsdfsdfsdghtrhrth"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")