re = /\d+:\d+(?:(?!\d+:\d)[\s\S])*/
str = '1:1 wefeff qwefejä qwefjk
dfjdf 10:2 jdskjdksdjö
12:1 qwe qwe: qwertyå'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end