using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^block )\w+\n";
string input = @"extends standard
block head
<title>title</title>
<meta name=""description"" content=""A wonderful thing."">
block body
<h1>Title</h1>
<p>A wonderful paragraph...</p>
block scripts
<script src=""/javascritps/html5shiv.js""></script>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}