re = /(?<=^block )\w+\n/m
str = 'extends standard
block head
<title>title</title>
<meta name="description" content="A wonderful thing.">
block body
<h1>Title</h1>
<p>A wonderful paragraph...</p>
block scripts
<script src="/javascritps/html5shiv.js"></script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end