import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\d{6}|(?:.*\\d){9})[A-Za-z\\d]+$";
final String string = "12345\n"
+ "Yograj\n"
+ "Yograj123456\n"
+ "12345Yograj\n"
+ "12345Yograj12345\n"
+ "Yograj123456Yograj\n"
+ "Yograj123Varsolkar456789\n"
+ "123Yograj45678Varsolkar\n"
+ "A1B2C3D4e5f6g7h8i9j0\n"
+ "Yograj 890 Varsolkar 78455\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}