package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)"[^"]*"|\b(Internet)\b`)
var str = `Internet "InternetFormula works and it's internetformula" Internet
Internet "The internet works"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}