$re = '/"[^"]*"|\b(Internet)\b/im';
$str = 'Internet "InternetFormula works and it\'s internetformula" Internet
Internet "The internet works"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);