#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![EB]#)[A-G](\#|b)?"
Local $sString = "A" & @CRLF & _
"A#" & @CRLF & _
"Ab" & @CRLF & _
"B" & @CRLF & _
"Bb" & @CRLF & _
"C" & @CRLF & _
"C#" & @CRLF & _
"Cb" & @CRLF & _
"D" & @CRLF & _
"D#" & @CRLF & _
"Db" & @CRLF & _
"E" & @CRLF & _
"Eb" & @CRLF & _
"F" & @CRLF & _
"F#" & @CRLF & _
"Fb" & @CRLF & _
"G" & @CRLF & _
"G#" & @CRLF & _
"Gb" & @CRLF & _
"B#" & @CRLF & _
"E#" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")