# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[a-z] + [^0-9\s.]+|\.(?!\d)//g;t' <<< "asdsad $59.33 9. .3 as.df 2 asdf 56 89 .a 2.4 wef 95 as.5df. 67.990 dssdgsfh.gdfgdlkblbllgff.njyn.j.njljn.jn.j.jnjnn.jn.n.n.vvfbvhfbhbfhbvhfbvhf.ghfghrughu.gktigjti"