import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<prod>\\w+)-(?P<maj>\\d).(?P<min>\\d).(?P<bug>\\d)(?:-(?P<pre>alpha|beta|rc)(?:\\.(?P<pre_n>\\d))?(?:\\.(?P<pre_x>\\w+))?(?<!centos|redhat))?(?:\\.(?P<os>centos|redhat))?(?:\\.(?P<plat>snb|ivb))?$";
final String string = "foo-1.2.3\n"
+ "foo-2.3.4-alpha\n"
+ "foo-3.4.5-rc.2\n"
+ "foo-4.5.6-rc.2.extra\n"
+ "withos-5.6.7.centos\n"
+ "osandextra-7.8.9-rc.foo.redhat\n"
+ "os_and_plat-4.4.4-rc.1.foo.centos.ivb\n\n\n"
+ "issue-0.1.0-beta.redhat.snb\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}