#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\<(contentplace)(\s+zone="(\w+)")?(\s+order="(\d{1,5})")?\s*\>(([\s|\S]*?)*?)\<\/\1>"
Local $sString = "<contentplace" & @CRLF & _
" zone="top">hgjgh jksdh</contentplace>" & @CRLF & _
"" & @CRLF & _
"<contentplace zone="bottom">" & @CRLF & _
"asdasd" & @CRLF & _
"sadklsalkdsdk</contentplace>" & @CRLF & _
"</contentplace>" & @CRLF & _
"" & @CRLF & _
"<contentplace zone="left" order="1">" & @CRLF & _
"<div>" & @CRLF & _
" match any charachters" & @CRLF & _
"</div>" & @CRLF & _
"</contentplace>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")