const regex = /\<(contentplace)(\s+zone="(\w+)")?(\s+order="(\d{1,5})")?\s*\>(([\s|\S]*?)*?)\<\/\1>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<(contentplace)(\\s+zone="(\\w+)")?(\\s+order="(\\d{1,5})")?\\s*\\>(([\\s|\\S]*?)*?)\\<\\\/\\1>', 'gmi')
const str = `<contentplace
zone="top">hgjgh jksdh</contentplace>
<contentplace zone="bottom">
asdasd
sadklsalkdsdk</contentplace>
</contentplace>
<contentplace zone="left" order="1">
<div>
match any charachters
</div>
</contentplace>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}