using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)(\.\w+)+(?!.*(\w+)(\.\w+)+)";
string input = @"https://my.website.com/reports?ref_=kdp_BS
https://my.website.com/reports.html";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}