# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\D)(?=\d+\b)/,/g;t' <<< "NS01SP0001
ns01sp0001"