$re = '~[cf]=("[ a-zA-Z0-9_/-]+\.(js|html)")~';
$str = '<script src="foo.js"...
<link rel="import" href="bar.html"...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);