#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((\[\d+:\d+:\d+ \w+\][\w ]+:)|(\[\d+:\d+:\d+ \w+ \| \w+ \d+:\d+:\d+ \w+\][\w ]+:))([ \w'.,]+)"
Local $sString = "[9:14:51 AM] Jeff: If you could just do me a favoure and list all these concerns and in a mail and if you have any ideas that you might want to implement so that I can get everybodys notes." & @CRLF & _
"[9:14:56 AM] Timmy: in terms of websites or domains or DNSs I have no clue about setup" & @CRLF & _
"[9:15:19 AM | Edited 9:15:25 AM] Jeff: That, I will get Sam and Frodo involved in" & @CRLF & _
"[9:16:01 AM] Jeff: I am stepping out quickly"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)