# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\[\d+:\d+:\d+ \w+\][\w ]+:)|(\[\d+:\d+:\d+ \w+ \| \w+ \d+:\d+:\d+ \w+\][\w ]+:))([ \w'.,]+)"
test_str = ("[9:14:51 AM] Jeff: If you could just do me a favoure and list all these concerns and in a mail and if you have any ideas that you might want to implement so that I can get everybodys notes.\n"
"[9:14:56 AM] Timmy: in terms of websites or domains or DNSs I have no clue about setup\n"
"[9:15:19 AM | Edited 9:15:25 AM] Jeff: That, I will get Sam and Frodo involved in\n"
"[9:16:01 AM] Jeff: I am stepping out quickly")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.