re = /((\[IMG WIDTH\=[\d]+ HEIGHT\=[\d]+])(.*)(\[\/IMG\]))/
str = '[IMG WIDTH=604 HEIGHT=467]http://img1.joyreactor.cc/pics/post/%D0%BA%D0%BE%D1%82%D0%B8%D0%BA%D0%B8-%D0%B6%D0%B8%D0%B2%D0%BD%D0%BE%D1%81%D1%82%D1%8C-%D0%B4%D0%BB%D0%B8%D0%BD%D0%BD%D0%BE%D0%BF%D0%BE%D1%81%D1%82-%D0%BF%D0%B5%D1%81%D0%BE%D1%87%D0%BD%D0%B8%D1%86%D0%B0-1170505.jpeg[/IMG][IMG WIDTH=604 HEIGHT=467]http://img1.joyreactor.cc/pics/post/%D0%BA%D0%BE%D1%82%D0%B8%D0%BA%D0%B8-%D0%B6%D0%B8%D0%B2%D0%BD%D0%BE%D1%81%D1%82%D1%8C-%D0%B4%D0%BB%D0%B8%D0%BD%D0%BD%D0%BE%D0%BF%D0%BE%D1%81%D1%82-%D0%BF%D0%B5%D1%81%D0%BE%D1%87%D0%BD%D0%B8%D1%86%D0%B0-1170505.jpeg[/IMG]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end