using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}";
string input = @"192.168.0.1
2192.168.0.1
192.2168.0.1
192.1.0.1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}